To run OpenCms you need

  • a Java SE Development Kit (JDK)
  • a database management system (DBMS)
  • a servlet container
  • and for server installation a front-end webserver (e.g., Apache)

Here we give an overview on versions of these software components where OpenCms 9.5 is tested on.

That does not mean that you are tied to these versions, but they are recommended.

JDK

  • Java SE Development Kit 6 (tested)
  • Java SE Development Kit 7 (recommended)
  • Java SE Development Kit 8 (untested)

DBMS

OpenCms can connect to several different database management systems. The list provides an overview on the various provided database connectors and the DBMS versions for which the connetors are tested. Probably the connectors work also for newer versions of the DBMSs.

Only the connectors that are displayed bold are officially supported by Alkacon Software GmbH, the main developer of OpenCms.
  • MySQL
    • MySQL Community Server 5.1 (tested)
    • MySQL Community Server 5.5 (tested)
    • MySQL Community Server 5.6 (recommended)
  • Oracle
    • Oracle 9i (tested)
    • Oracle 10g (tested)
    • Oracle 11g (tested)
  • PostgreSQL
    • PostgreSQL 7.4.x (tested)
    • PostgreSQL > 7.4.x (untested)
  • MS SQL Server
    • MS SQL Server 2000 (tested)
    • MS SQL Server 2005 (tested)
  • DB2
    • DB2 9.7.x (tested)
  • AS400
  • HSQLDB
    • HSQLDB 1.8.0 (tested)
  • PostgreSQL (JPA based)
    • PostgreSQL 7.4.x or newer
  • MS SQL Server (JPA based)
  • HSQLDB (JPA based)
  • Apache Derby (JPA based)
  • Borland INterbase (JPA based)
  • Borland JDataStore (JPA based)
  • Empress (JPA based)
  • Firebird (JPA based)
  • H2 Database Engine (JPA based)
  • Informix Dynamic Server (JPA based)
  • InterSystems Cache (JPA based)
  • Sybase Adaptive Server (JPA based)

Servlet container

OpenCms requires a Servlet 2.4 / JSP 2.0 standards compliant container. It should work with every servlet container fulfilling this requirements.

  • ¬†Tomcat
    • Tomcat 6.0 (tested)
    • Tomcat 7.0 (recommended)
    • Tomcat 8.0 (untested)

Webserver

  • Apache
    • Apache 2.2 (tested)
    • Apache 2.4 (recommended)